
Advanced Features
of Excel

Formatting Data in a Worksheet

 Learning Objectives

·

·

·

·

Formatting data and Worksheet structure

Selecting a row or column and changing its height and width

Inserting a blank row and column

File operations

You can format data to enhance its look by applying different fonts, styles, and borders. You can 
also format the worksheet structure, like changing the height of  rows, width of  columns, etc., as per 
your requirement.

You should know how to format the data entered in different cells, like changing the font type, size, 
and alignment. It can make the contents look organized and attractive. To do this, you must first 
click on the Home tab and then the command buttons specific to the type of  formatting required, 
under the Font group (shown below) 

Font type Font size Font ColorFill Color

Left
Center

RightBold
Italic

Underline

Border

You can change the appearance of  the typed entry by choosing the Font type. Click the Font type 
arrowhead button and select the required font type from the list.

Changing the Font Type

You can change the font size of  the selected data range by clicking on the Font size. Click the Font 
size arrowhead button and select the required font size from the list.

Changing the Font Size
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The entries can be made Bold, Italic, or Underlined. Just 
click the Font style button for the style you want to apply 
to a selected data range.

Changing the Font Style

You can change the font colour for the entries by clicking on the Font Color arrowhead button and 
then selecting the colour of  your choice.

Changing the Font Colour

You can change the background colour of  the selected cells by clicking on the Fill Color arrowhead 
button and selecting the preferred background colour.

Changing the Background Colour

You can choose the preferred alignment for the selected data by clicking on 
the corresponding alignment button (Align Text Left, Align Text Center, 
or Align Text Right).

Setting the Alignment

There are various types of  borders that you can apply to the worksheet data 
by clicking on the Border arrowhead button. The most common type of  
border to use is All Borders (     ). To remove the border, select the No 
Border option.

Applying a Border

Formatting the Worksheet Structure

You can also change the 'height' and 'width' of  the rows and columns to suit your requirement. You 
can also insert new rows/columns. To do this, you must first select the rows and columns you want 
to work on.

To select a row, click on the row header (the 
area where the row address is written).

Selecting a Row

To select a column, click on the column header 
(the area where the column address is written).

Selecting a Column
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To change the column width, drag the boundary which is to the right of  the column header— left or 
right until the width changes as per your requirement.

Changing the Column Width

To change the row height, drag the bottom boundary of  that particular row Up or Down, as required.
Changing the Row Height

To accommodate additional records, you can add blank rows to your worksheet.

Activity: Steps to add a blank row in a worksheet:

Inserting a Blank Row

Step 1: Select the row (or place the cell pointer in any row cell) above which you want to insert an empty row.

2

3

4
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The changed column width

The changed row height

To select multiple adjacent rows/columns, keep the Shift key pressed; 
to select non-adjacent rows/columns, keep the Ctrl key pressed.

1



Step 2:

Step 3:

Step 4:

Click on the Home tab.

Click on the Insert arrowhead button under Cells 
group

Click on the Insert Sheet Rows option.

...The row will be inserted.

To accommodate additional fields, you can add blank columns to your worksheet.

 Steps to add a blank columnActivity:

Inserting a Blank Column

Step 1:

Step 2:

Step 3:

Step 4:

Select the column or (place the cell pointer in any cell of  the 
column), before which you want to insert a blank column.

Click on the Home tab.

Click the Insert arrowhead button.

Click on the Insert Sheet Columns option.

1

4

3

...The blank 
column will be 
inserted before the 
selected column.

File Operations

Now, your workbook is ready, and you can open it, save it or close it when required.

It is essential to save your workbook on a disk to refer to it later when needed.

 To save a workbookActivity:

Saving a Workbook

Step 1:

Step 2:

Step 3:

Click on the File tab. The Backstage view will appear. Click on the Save 
option.

The Save As pane appears. Here, you can save your workbook. Let us say 
that we want to save it on our computer in some folder.

Click on the Browse button. It displays the Save As dialog box, in which 
you assign a name to the file and save it to the desired location.

Remember
The Save option allows you to save a document in the same location with the same name. With 
Save As option, you can save a document with a different name and/or a different location.
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under the Cells group.

Saving a workbook



Whenever you want to open any workbook which you saved earlier, you have to follow the steps 
given below:

 To open a saved workbook:Activity:

Opening a Saved Workbook

Step 1:

Step 2:

Step 3:

Click on the File tab. The Backstage view will appear. 
Click on the Open option. The Open pane appears. 

Click on the Browse button. The Open dialog box 
opens.

Select the workbook to open from the required location 
and click on the Open button.

...The selected workbook will open.

Remember
You can also open a worksheet from the recently opened worksheets.

When your work with the current workbook is over, you can close it. The steps to close a workbook 
are as follows:

Closing the Workbook

Step 1: Step 2:Click on the File tab. Select the Close option.
...The workbook will close.

To start a new task, you need to open a new workbook. Follow these steps to open a new workbook:
Opening a New Workbook

Step 1: Step 2:Click on the File tab. Select the New option and click on the Blank Workbook icon
...A blank workbook will open on your computer screen.

Remember
The Ribbon contains the set of  commands for working in a workbook. At the same time, the 
Microsoft Office Backstage view is the set of  commands (like open, save and print) you use to do 
things to a workbook.

Printing Time

You can print entire or partial worksheets and workbooks. Let us see how it is done.

 To use the Print command:Activity:

Step 1:

Step 2:

Click on the File Tab. The Backstage view appears. Click on the Print option.

The Print pane opens.
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Step 3:

Step 4:

Step 5:

Enable the required options in the Settings 
section; the meaning of  each option is as follows:
a. Print Active Sheets: Select this option if  you 

want to print the current worksheet (or 
selected worksheets)

b. Print Entire workbook: Select this option if  
you want to print the whole workbook.

c. Print Selection: Select this option to print 
the selected range.

Change the page orientation here.

Select the desired option from the Scaling drop-
down menu. For example, if  we select the Fit All 
Columns on One Page option under the 
Custom Scaling option. The worksheet will be 
condensed to fit onto a single page.

Remember
Multiple adjacent worksheets can be selected/printed by holding down the Shift key and clicking 
on the first and last worksheet tabs. You can select non-adjacent worksheets by holding down the 
Ctrl key and clicking on the required worksheet tabs.

Quick Recap

·

·

·

·

·

·

·

·

The Ribbon contains the set of  commands for working in a workbook. At the same time, the 
Microsoft Office Backstage view is the set of  commands (like open, save and print) you use to 
do things to a workbook.

You can format data to enhance its look by applying different fonts, styles, and borders.

To do this, you must first click on the Home tab and then the command buttons specific to the 
type of  formatting required, under the Font group

You can change the font colour for the entries by clicking on the Font Color arrowhead button 
and then selecting the colour of  your choice.

You can change the background colour of  the selected cells by clicking on the Fill Color 
arrowhead button and selecting the preferred background colour

The most common type of  border to use is All Borders ( ).

To change the column width, drag the boundary which is to the right of  the column header— 
left or right until the width changes as per your requirement.

To change the row height, drag the bottom boundary of  that particular row Up or Down, as 
required. To accommodate additional fields, you can add blank columns to your worksheet.
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Design a worksheet as given below. 

Step 1:

Step 2:

Step 3:

Step 4:

Step 5:

Step 6:

Step 7:

Select row 3 and click on the Home tab.

Click on the bold style button in the Font group.

Select the cell range B4:B10 and click on the Italic style botton in the Font 
group.

Select cells range A4:A10, click the Fill Color arrowhead button, and select 
the yellow background colour.

Select columns B and C and click on the Center button in the Alignment 
group.

Select the cell range A3:C10 and click the More Border arrowhead button. 
Select Outside Border and All Borders.

 Click on the File tab. Click on the Save option. The Save As pane appears. 
Here, you can save your workbook with your desired name.

The output will look like this:

a. Apply bold font style to row 3 and Italic style to the contents of  
the cell range B4:B10.

b. Apply a yellow background colour to cells range A4:A10.

c. Centre align the contents of  Column B and column C. 

d. Add Thick Outside Borders and  All Borders to cell range 
A3:C10. 

e. Save the workbook.

Exercise Time

A. Tick (ü) the correct answer.

1. Columns in MS Excel are named in the form of  ______.

a. Alphabets (A, B, C, D,...) b. Numbers (1,2,3,4,...)

c. Roman numerals (I,II, III, IV,...) d. none of  them

2. On which tab you will find the Font group?

a. Data b. Home 

c. view d. insert

Practice Time
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3. On which tab you will find the save option to save a  workbook?

a. Home b. Data

c. File d. formula 

4. To select multiple adjacent rows/ columns, keep the _____key pressed

a. Shift b. Ctrl

c. Enter d. Spacebar

5. In which group you will find the bold button?

a. Font b. Alignment

c. Styles d. cells

C. Write (T) for True and (F) for False.

1. We cannot add a border to a single cell. 

2. We can fill the desired colour to selected cells. 

3. Once we enter data, we cannot change the width of  the column. 

4. You can print entire or partial worksheets and workbooks. 

5. You cannot insert new rows/ columns in a worksheet. 

B. Fill in the blanks.

 

1. By default, the text is  aligned in a cell.  

2. To select a row, click on row  .

3. You can also open a worksheet from the  opened worksheets. 

4. The  contains the set of  commands for working in a workbook. 

5. You can change the background colour of  the selected cells by clicking on the  
arrowhead button. 

.............................

.............................

.............................

.............................

.............................

Fill Color                     Recently                     left                    Ribbon                    header  

D. Answer the following questions.

1. How can you open a blank workbook?

2. What is row header and column header?

3. Which alphabet or number represents a row in the cell address F3?

4. How can you add a border to a cell?

.........................................................................................................................................................................

.........................................................................................................................................................................

.........................................................................................................................................................................

.........................................................................................................................................................................
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Help Ishi to fill in the correct terms or draw icons.

Worksheets
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