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Chapter 1- Development of Computers
A. Tick (ü) the correct answer.

1. d. Abacus 2. c. Blaise Pascal 3. a. Charles Babbage

4. a. Portable computer 5. c. Tablet 6. a. ALU and CU

7. c. Microchips

B. Fill in the blanks.

1. John Napier 2. Blaise Pascal 3. RAM

4. ALU and CU  5. Secondary memory 6. Binary

7. TB 8. Cloud

C. Write (T) for True and (F) for False.

1. T 2. T 3. F 4. T 5. F

6. F 7. T 8. F 9. F

D. Answer the following questions.

1.  The major operations performed by the ALU are addition, subtraction, multiplication, division, logic 

(True/ False) and comparison.

2. The main circuit in a computer system is called the motherboard.

3. Secondary memory consists of storage devices. Examples of secondary storage are USB drives, CDs, 

HDD, etc

4. SSDs are faster, more durable, compact, quieter, and consume less energy than HDDs. That's why SSD is 

preferred over HDD.

5. The contents of the RAM get erased as soon as the computer is switched off. There fore RAM is called 

temporary memory. 

E. Think and answer (Oral Questions).

1.  Tablet

2.  Cloud storage like Google Drive. 

3. Larger memory - RAM.

Chapter 2- Page Formatting in MS Office Word 2019
A. Tick (ü) the correct answer.

1. b. Header

2. a. Footer

3. c. Page

4. c. Border

5. b. No border

6. c. Borders & Shading dialog box

7. b. Background colour applied to a paragraph

B. Fill in the blanks.

1. Insert, Header 2. Layout 3. Page Break 4. Page Number

5. Home 6. Horizontal,  Vertical
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C. Write (T) for True and (F) for False.

1. T 2. F 3. T 4. F 5. F 6. F 7.  T

D. Answer the following questions.

1. header- sun and his sons, footer- solar system journey

2. A page break is a special marker that will end the current page and start a new one. To make sure the 
title page of your project is separate from the other page, for example, insert a page break after the last 
line on the title page.

3. This can be in the header or footer, and located left, center, or right.

4. Click on the Layout tab to create columns in your document

5. You can use landscape page orientation for printing a graph or wider scenery.

E. Think and answer (Oral Questions).

1. To insert a Header in your document:

Step 1: Click on the Insert tab.

Step 2: Click on the Header button.

Step 3: The Header Gallery opens. Select the Header type from the list of headers displayed.

Step 4: Click on the Header placeholder and type the name. Clicking on the Insert tab while the cursor is 
in the Header section, insert the desired picture.

2. She can insert the page number.

3. He can apply shading to paragraphs.

4. He can apply landscape settings to the poster with an attractive border.

Chapter 3- Advanced Features of Word

A. Tick (ü) the correct answer.

1. a. Not change the misspelt word

2. d. Change all occurrences of the word

3. b. Thesaurus

4. d. Track Changes option

5. c. Review tab

6. d. Draw

7. a. Insert

B. Fill in the blanks.

1. Insert  2. Illustrations 3. Pens,   Draw 4.  Mail merge 

5. Review,   Track changes 

C. Write (T) for True and (F) for False.

1. F 2. F 3. F 4. T 5. F

D. Answer the following questions.

1. Review tab

2. Review tab

3. When someone changes a word document, it becomes impossible to find out what the text looked like 
in its unedited form. So, to keep track of these changes—that MS Word offers the Track Changes option.

4. The Thesaurus feature gives you the option to find synonyms for a word.
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E. Think and answer (Oral Questions).

1. Word Count feature in the Proofing group under the Review tab Spelling & Grammar button in Proofing 

group under the Review tab To find the synonyms for a word:

Step 1: Right Click on the word

Step 2: In the Shortcut menu, point to the Synonyms option.

Step 3: Click on the required word from the list of synonyms.

2. Charu used the track changes option.

To accept/reject the tracked changes one by one:

Step 1: Click on the Review tab.

Step 2: Click on the Next button.

Step 3: Click on the Accept arrowhead button. Select Accept and move to the Next option

Chapter 4- Working in MS Office PowerPoint 2019

A. Tick (ü) the correct answer.

1. d. all of them 2. a. F5 3. b. Normal view

4. b. Home 5. a. Zoomed 6. d. All of these

B. Fill in the blanks.

1. Slide Sorter 2. full-screen 3. Placeholders 4. Title,  subtitle 5. visual

C. Write (T) for True and (F) for False.

1. F 2. T 3. T 4. F 5. T

D. Answer the following questions.

1. PowerPoint—a part of Microsoft's Office Suite—is a presentation program developed by Microsoft. It 

comes with the necessary features to create digital slide shows. It allows you to include multimedia 

content like pictures, audio, video clips and animation in your presentation.

2. A theme is a predefined combination of a background and a colour scheme for a presentation.

3. The Slide Sorter view is the view of all the slides in a presentation in their Thumbnail form. This view 

gives you an overall picture of the presentation, making it easy for you to reorder, add or delete slides.

4. Yes. Select the slide that you want to delete and press the Delete button OR you can right-click on the 

slide and then select the Delete slide option.

5. To add a table to a slide:

Step 1:Click on the Insert Table icon in the content placeholder.

Step 2:The Insert Table dialog box opens. Enter the number of Rows and Columns. Click on the OK 

button....The table will be inserted.

E. Think and answer (Oral Questions).

1. She can use the numbered list from the Paragraph group under the Home tab.

2. Slide Sorter View

3. She can apply themes.To create a new presentation using a theme:

Step 1: Click on the File tab, then click on the New option.

Step 2: The New Presentation window opens.

Step 3: Select a theme.

Step 4: Click on the Create button.

4. The reason could be that the file format is not supported by PowerPoint.
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Chapter 5- Background and Animations in PowerPoint

A. Tick (ü) the correct answer.

1. b. Design 2. b. None 3. d. All of the above

4. d. Slide Transition 5. d. All of these

B. Fill in the blanks.

1. Animation 2. Duration 3. F5 4. Transition effect 5. Entrance

C. Write (T) for True and (F) for False.

1. F 2. T 3. F 4. T 5. F

D. Answer the following questions.

1.  The special effect with which a slide is introduced in a presentation is called the transition effect.

2. Animation is the effects applied to any object on slides to make the object move.

3. In Slide Show, all slides will be displayed one by one in full view. OR The Slide Show view is the full-screen 

view in which you see your presentation  the way your audience will see it.

4. To view the slide show

Step 1: Click on the Slide Show tab.

Step 2: Click the From Beginning button from the start Slide show group.

...The Slide Show will start. You can also begin to the slide show by pressing the F5 key.

5. Themes in PowerPoint are design settings with predefined colours and font properties.

OR 

Themes are ready-made combinations of background, font settings and layout, all of which work 

together to create your presentation.

E. Think and answer (Oral Questions).

1. To make the slide advance automatically, select the After check box in the Timing group of the 

Transition tab, and then enter the 5 seconds.The timer starts when the final animation or other effects 

on the slide finish.

2. He should click the Transition tab and select theSound option in the Timing group.

3.  She can click the Effect Options button in the Animation group under the Animation tab and select the 

"From Right" option.

Chapter 6- Introducing MS Office Excel 2019

A. Tick (ü) the correct answer.

1. b. Computer Programs 2.  c. Cells 3. b. Data

4. b. Column address

5. c. Name box

6. The central place in the Excel screen from where all functions are carried out is called the

7. b. Copy and Paste

8.  a. Cut and Paste

9. c. Auto Sum

10.b. Sorting
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B. Fill in the blanks.

1. Rows,   Columns 2.  Workbook 3.  Select 4. Cut,   Paste 5.  Sort    6.  Auto Sum

C. Write (T) for True and (F) for False.

1. F 2. T 3. T 4. F 5. F 6. T

D. Answer the following questions.

1. A worksheet in Excel consists of a grid of rows and columns which intersect to form cells in which you 

enter data.

2. An Excel document is called a workbook and is saved with the extension .xlsx. Just as a notebook 

consists of many sheets, a workbook in Excel consists of a number of worksheets.

3. Each cell address in a worksheet is referred to as a column-row combination (like B2, D4, E5, etc.). Here 

the first character (B, D, E,...) represents the Column address, and the second character (2, 4, 5,…) 

represents the Row address.

4. When you click on a cell, it becomes active.

5. Home, Insert, Page Layout, Formulas, Data, Review, View, and Help tabs.

6. It means cell range from A1 to A7.

E. Think and answer (Oral Questions).

1. To sort the data:

Step 1: Select the data to sort.

Step 2: Click on the Home tab.

Step 3: Click on the Sort & Filter arrowhead button. 

Step 4: Select the required Sort option.

2.  She can click on a cell and see and edit its contents in the Formula bar.

3.  He can use the AutoSum option. To Use the AutoSum option:

Step 1: Click on the empty cell after the last entry in the range of cells.

Step 2: Click on the Home tab.

Step 3: Click on AutoSum.

Step 4: The formula for the sum of the range of numbers above it will appear in the Active cell.

Step 5: Press the Enter key to display the sum.

Chapter 7- Problem Solving

A. Tick (ü) the correct answer.

1. a. Algorithm

2. c. Flowchart

3. d. Flow lines

4. c. Terminal box

5. d. Processing box

6. c. Input/Output box

7. b. Decision box

B. Fill in the blanks.

1. Algorithm 2. Flow chart 3. Terminal 4. Input/Output  5. Processing 6. Start,  Stop
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C. Write (T) for True and (F) for False.

1. F 2. T 3. T 4. F 5. T 6. T

D. Answer the following questions.

1.  The input/Output box is used to suggest the data input or output of information.

2. A decision box is used for decision-making.

3.  An Input/Output box can be used to print the sum of two numbers.

4. An Input/Output box can be used for the instruction INPUT X.

5. C=A-B

E. Think and answer (Oral Questions).

1. The comparison should be made in the decision box, not the Input/Output box.

2. INPUT A

3. avg=(n1+n2+n3)/3 Print avg

Chapter 8- Creating Animated Games in Scratch 3.0

A. Tick (ü) the correct answer.

1. c. Sprites

2. c. block categories

3. b. Control

4. d. green

5. c. Stamp

6. c. Looks

7. c. Looks

B. Fill in the blanks.

1. Sprites 2. Categories 3. Scripts 4. Costume 5. Sound

6. Clean up 7. Looks

C. Write (T) for True and (F) for False.

1. T 2. F 3. F 4. T 5. F 6. F 7. F 8. T

D. Answer the following questions.

1. Block Description area, Blocks Palette, Menu bar, Scripts area, Green flag, Red stop, Stage, Full screen control

2. Following are the block categories in Scratch 3.0

Motion,Looks,Sound,Events,Control,Sensing,Operators,Variables,Lists,My Blocks.

There are some extension categories also, like Music, Pen, Video Sensing etc

3. Scripts are executed from top to bottom. Scripts are made up by adding and connecting different blocks.

4. Code tab, Costumes tab, Sounds tab

5. Turning block-Add a required "Turn" block underneath or on top of the current block. You can turn the 

Sprite from 15 to any number (angle).

Go to (x) (y)-It brings the Sprite to the desired x, and y coordinates on the screen. x=0 and y=0 will bring 

the Sprite to the center of the screen.

If on Edge, Bounce-When the Sprite touches the edge, it will face in the opposite direction (i.e., it will 

turn 180 degrees).
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6. Repeat-If you want to repeat a set of instructions many times, put that script inside the Repeat block.

Wait-When during the execution of commands, you want to give a little pause, the wait block is used.

When Green Flag is clicked-You can execute the instructions on clicking the Green Flag.

7. We can use the "If on Edge, Bounce" block.

8. The Looks block category has blocks to change the Sprite's colour and size and add dialogues to the 

sprites.

9. Ask What's your name? and the wait block-This block will prompt the user to enter the keyboard input. 

The input will be stored in the answer block. This answer block can be placed inside the Say block from 

the Looks block category to display the answer. Answer block-As mentioned, it will store the keyboard 

input from the prompt

E. Think and answer (Oral Questions).

1. dialogues to the Sprite, changing size and colour

2. Video sensing is a new extension added to the Scratch 3.0 programming environment. It uses a video 

camera as a sensor to detect motion and colour. Scratch allows learners to control digital animations 

with physical interactions using moving objects or specific colours seen through a camera.

Chapter 9- WWW, E-Mail and Cyber security

A. Tick (ü) the correct answer.

1. d. WWW

2. a. Website

3. c. Hyperlink

4.  c. Search Engine

5. a. Internet Directories

6. a. Search box

7.  b. Keywords

8. a. Yes

9. d. all of the above

10. d. No access required

B. Fill in the blanks.

1. Hyperlink 2. Home page 3. Search box 4. Keywords

5. @ 6. Cc 7. Private 8. Passwords

C. Write (T) for True and (F) for False.

1. T 2. F 3. F 4. T 5. T

6. F 7. F 8. F 9. T 10. F

D. Answer the following questions.

1. WWW is often referred to as the "graphical side" of the Internet.

2. A Search Engine is a website designed to search for information on the World Wide Web.

3. A web page is a digital page of information on the Internet containing text, pictures, animation and sound.

4. A hyperlink is an image or portion of text that opens the linked web page when clicked.

5. Uniform Resource Locator (URL)
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6. Transferring information from the Internet onto your computer.

7. Attachment can be a picture, a song or a video clip file that can be sentby attaching it with your e-mail 

message.

8. Google Translate is a free, multilingual translation service provided by Google to translate written text from 

one language to another.

9. Phishing is a cyber-attack often used to steal user data, includinglogin credentials and credit card numbers.

10. 2FA is an extra layer of security used to ensure that people trying to gain access to an online account are 

who they say they are. First, a user will enter their username and password. Then, instead of immediately 

gaining access, they must provide other information.

E. Think and answer (Oral Questions).

1. He can share the web page link with his friend.

Download a page from Chrome to read offline, and You must be online to save a page.

1. On your computer, open Chrome.

2. Go to a page you want to save.

3. At the top right, click  Three vertical dotsMore Tools >Save page as.

4. Choose where you want to save the page.

5. Click Save.

To read a saved page, open the file on your computer. It will open in your default browser, like Chrome 

or Safari.

2. Ruchi has found an interesting picture on a web page and wants to use it in her project work. Write 

down the steps she should follow to save it.

Step 1: Open the web page which has the picture that you want to save.

Step 2: Right-click on the picture. A shortcut menu will appear.

Step 3: Click on the Save Image As option.

Step 4: The Save Picture dialog box opens. In the File Name box, give a name to the picture.

Step 5: Click on the Save button.

...The picture will be saved with the given name

3. "Canon digital camera"

4. Suppose you share your address on a social networking site. In that case, you open yourself up to 

threats of identity theft and other personal dangers like burglaries. If you post that you're going on 

vacation and have your address posted, everyone knows you have an empty house.

Chapter 10- More on Artificial Intelligence

A. Tick (ü) the correct answer.

1. a 2. c 3.  b 4.  c 5.  c

B. Fill in the blanks.

1. Artificial intelligence

2. smart home

3. education

4. IPA

5. Chabot
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C. Write (T) for True and (F) for False.

1. F 2. T 3. T 4. F 5. T 6. T

D. Answer the following questions.

1. Human beings are the creator of machines, giving them the ability to make decisions. Also, machines and 
robots cannot become exactly like humans, it is just work like them. This is the reason Artificial Intelligence 
got the word Artificial.

2. A smart home is equipped with lighting, heating, and electronic devices that can be controlled remotely by 
smartphone or computer.

3. Alexa,Cortana,Echo Dot,Siri

4. Apple uses Siri, and Google uses Google Assistant

5. Chatbot

6. AI in education generally focuses on identifying what a student does and doesn't know through diagnostic 
testing and then developing personalized courses based on each student's specific needs.

E. Think and answer (Oral Questions).

1. Door lock, Central AC, Smart light

2. AI also can present full-time 24-hour availability to lessons and teachers anywhere. Based on AI 
algorithms, it can provide students with personalized feedback on quizzes, coursework, etc.
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